Jump to content
  • 0
Cubert

Upgrade Labtech RDP Client for FullScreen functionality

Question

Fellow LT Geekers,

 

I created a how to blog on making a new redirector with a updated RDP client that will do real full screen when launched and not the old 1024X1280 screen that come by default.

 

I put together a how-to that will explain how to add a newer RDP client to Labtech and push out full screen when selected.

 

http://www.squidworks.net/2013/10/labtech-how-to-have-a-full-screen-remote-desktop-client-redirector/

 

 

I have also tested it using a Windows 8 workstation and worked very well using the Windows 7 RDP app.

 

Fell free to comment on the process or if you have any trouble with the redirector. There are extra switches in my command to launch RDP so do not just copy the original RDP command lines as this will cause Stun to drop when RDP session tries to authenticate across STun.

 

 

Cubert :shock:

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0

I think I followed the instructions correctly and I have checked it several times, but the redirector gives an error every time stating "cannot find "RDP""?

 

I found it odd that both your and the built in redirector point to %programfiles%\LabTech Client\RDP\LabTech1.rdp yet on a x64 machine the correct path is %programfiles(x86)%\LabTech Client\RDP\LabTech1.rdp since the CC is 32bit.

 

Also odd that there is a mstsc.exe in that directory to begin with as the built in redirector is pointing to it in %windir%\system32?

Share this post


Link to post
Share on other sites
  • 0

First since the CC is 32 bit this variable expands to the 32bit program files. - %programfiles%

 

 

Secondly the MSTSC.exe in the RDP folder is Windows XP version, OLD and does not support new features. The one in the System32 is newest. NOW the newer RDPs will not hold a process open so you need to prefix the Program with ! when using the System32 one

Share this post


Link to post
Share on other sites
  • 0

I followed these instructions, but get the same error the person above posted about. I copied the mtsc.exe from a 2008 R2 box instead of Windows 7. That's the only deviation that I made from the instructions. I'm running Labtech 2013

 

Argument used:

/c Type “%programfiles%\LabTech Client\RDP\LabTech1.rdp”>”%temp%\%computername%.rdp” & START “RDP” /WAIT “%programfiles%\LabTech Client\RDP\mstsc1.exe” “%temp%\%computername%.rdp” /public /V:%localip1%:%localport1%

 

Attached is the error.

Capture.JPG.908b9a9b9fbb7a2e1861ca2adc4a04d0.JPG

Share this post


Link to post
Share on other sites
  • 0

I think this might be the problem

 

“%programfiles%\LabTech Client\RDP\mstsc1.exe”

 

Is the file named mstsc1.exe?

 

OR maybe its the %programfiles% and change it to %startpath%

 

 

ALSO Check the QUOTES, I am seeing Outlook\Word quotes and not the standard "

 

greg

Share this post


Link to post
Share on other sites
  • 0

Ahh eureka! The quotes were the problem the whole time. Such a crazy oversight and more importantly awesome catch! lol

Share this post


Link to post
Share on other sites
  • 0

There is a much easier solution. Here is what I recently posted on the LT T/R Forums.

 

Simply adding the /f argument to the end of the arguments fields for the Remote Desktop options in the Redirector App configurations will force RDP to open in full screen mode. This change would be global too. Do not add the /f switch to the Remote Desktop Auto option though. It will likely break it since this option does not call MSTSC.exe directly per-se. If you're not looking for a global change, then modify the LabTech.rpd file (C:\Program Files (x86)\LabTech Client\RDP\) and save the changes. This is the RDP file that is called for the all LabTech default Remote Desktop connections.

 

p7SbZPi.png

Share this post


Link to post
Share on other sites
  • 0

Good day to you all. I am attempting to use the setup Cubert suggested as We still have some use for the version that doesn't go full screen, but keep getting the error

 

mstsc1.exe

The system cannot find the file specified.

C:\Program Files\LabTech Client\RDP\\mstsc1.exe.MUI (I couldn't get my saved screenshot to work so I typed the error out instead.)

 

And my Argument looks like

 

/c Type "%programfiles%\LabTech Client\RDP\LabTech1.rdp">"%temp%\%computername%.rdp" & START "RDP" /WAIT "%programfiles%\LabTech Client\RDP\mstsc1.exe" "%temp%\%computername%.rdp" /V:%localip1%:%localport1%

 

Any help on this matter is much appreciated as I have changed all the " from the word/outlook format, and have tried subbing in %startpath%, and confirmed that my file is in fact named mstsc1.exe, and that it does live at the location it claims it cannot find.

 

*Edit* Ignore. I got it to work with the other suggested post of just using the /f for the already installed RDP client.

 

Regards

 

David

Share this post


Link to post
Share on other sites
  • 0
Good day to you all. I am attempting to use the setup Cubert suggested as We still have some use for the version that doesn't go full screen, but keep getting the error

 

mstsc1.exe

The system cannot find the file specified.

C:\Program Files\LabTech Client\RDP\\mstsc1.exe.MUI (I couldn't get my saved screenshot to work so I typed the error out instead.)

 

And my Argument looks like

 

/c Type "%programfiles%\LabTech Client\RDP\LabTech1.rdp">"%temp%\%computername%.rdp" & START "RDP" /WAIT "%programfiles%\LabTech Client\RDP\mstsc1.exe" "%temp%\%computername%.rdp" /V:%localip1%:%localport1%

 

Any help on this matter is much appreciated as I have changed all the " from the word/outlook format, and have tried subbing in %startpath%, and confirmed that my file is in fact named mstsc1.exe, and that it does live at the location it claims it cannot find.

 

*Edit* Ignore. I got it to work with the other suggested post of just using the /f for the already installed RDP client.

 

Regards

 

David

 

This method requires modification and addition be made on every system with the Control Center. Please see the post above yours as its solution is global and doesn't require any local changes beyond simply adding a switch to the existing redirector configuration.

Share this post


Link to post
Share on other sites
  • 0
Good day to you all. I am attempting to use the setup Cubert suggested as We still have some use for the version that doesn't go full screen, but keep getting the error

 

mstsc1.exe

The system cannot find the file specified.

C:\Program Files\LabTech Client\RDP\\mstsc1.exe.MUI (I couldn't get my saved screenshot to work so I typed the error out instead.)

 

And my Argument looks like

 

/c Type "%programfiles%\LabTech Client\RDP\LabTech1.rdp">"%temp%\%computername%.rdp" & START "RDP" /WAIT "%programfiles%\LabTech Client\RDP\mstsc1.exe" "%temp%\%computername%.rdp" /V:%localip1%:%localport1%

 

Any help on this matter is much appreciated as I have changed all the " from the word/outlook format, and have tried subbing in %startpath%, and confirmed that my file is in fact named mstsc1.exe, and that it does live at the location it claims it cannot find.

 

*Edit* Ignore. I got it to work with the other suggested post of just using the /f for the already installed RDP client.

 

Regards

 

David

 

This method requires modification and addition be made on every system with the Control Center. Please see the post above yours as its solution is global and doesn't require any local changes beyond simply adding a switch to the existing redirector configuration.

 

 

Yes thank you that's What I did when I originally posted this to get it working. Has worked like a charm so far :)

Share this post


Link to post
Share on other sites
  • 0

Good stuff!

 

This argument actually worked for me..

/c Type "%programfiles%\LabTech Client\RDP\LabTech.rdp">"%temp%\%computername%.rdp" & START "RDP" /WAIT %windir%\system32\mstsc.exe "%temp%\%computername%.rdp" /f /admin /V:%localip1%:%localport1%

 

Cheers!

Share this post


Link to post
Share on other sites
  • 0
Fellow LT Geekers,

 

I created a how to blog on making a new redirector with a updated RDP client that will do real full screen when launched and not the old 1024X1280 screen that come by default.

 

I put together a how-to that will explain how to add a newer RDP client to Labtech and push out full screen when selected.

 

http://www.squidworks.net/2013/10/labtech-how-to-have-a-full-screen-remote-desktop-client-redirector/

 

 

I have also tested it using a Windows 8 workstation and worked very well using the Windows 7 RDP app.

 

Fell free to comment on the process or if you have any trouble with the redirector. There are extra switches in my command to launch RDP so do not just copy the original RDP command lines as this will cause Stun to drop when RDP session tries to authenticate across STun.

 

 

Cubert :shock:

 

 

OLD Post I know - but something i am looking to do at my new company.

 

Question: am i adjusting the mstsc on the Labtech server or my machine?

 

Thanks

Share this post


Link to post
Share on other sites
  • 0
There is a much easier solution. Here is what I recently posted on the LT T/R Forums.

 

Simply adding the /f argument to the end of the arguments fields for the Remote Desktop options in the Redirector App configurations will force RDP to open in full screen mode. This change would be global too. Do not add the /f switch to the Remote Desktop Auto option though. It will likely break it since this option does not call MSTSC.exe directly per-se. If you're not looking for a global change, then modify the LabTech.rpd file (C:\Program Files (x86)\LabTech Client\RDP\) and save the changes. This is the RDP file that is called for the all LabTech default Remote Desktop connections.

 

p7SbZPi.png

 

 

Where exactly on the argument field does the /f switch go? i have tried this and it didn't work.

 

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×